Working with Maps






Previous : Contents : Next

Saving a Map

There are a number of options when saving maps. The following can be saved.

  • A newly created map. Use Save All... on the File menu of the Librarian window.

  • A map that has been previously saved. Use the Save All... option on the File menu of the Librarian window to overwrite the existing file or to write to a different filename, preserving the previous version.

  • Part of a map. First select the modules that require saving (see Working with Modules in the Map Editor in the Using Modules chapter for instructions on how to do this). Then select Save Selected... under the File menu of the Librarian window to save those modules and the connections between them.

When saving a map, the file name must have an extension of .map, otherwise the file will not be recognised as a map by the Module Librarian.

Loading a Saved Map

If you load a map when a map is already loaded it will be added to the Map Editor. So, to load a saved map from scratch, destroy any other map you have first (see Destroying the Map in the Map Editor below).

There are two ways to load a map.
  • Use the File menu of the Librarian.
    • Select Open...
    • Use the file browser to find the map file
    • Select OK to load the map into the Map Editor
    • The map will execute
  • Use the Module Librarian to Launch the map.
    • Find the map in the Librarian
    • Select it with the left-hand mouse button
    • Drag outline the of the map to Map Editor and release the left-hand mouse button
    • The map will execute

Destroying the Map in the Map Editor

To destroy the entire map in the Map Editor, select Destroy All from the Edit menu in the Map editor.

To destroy part of a map (one or more modules and their connections), select the modules to be destroyed (see Working with Modules in the Map Editor in the Using Modules chapter for instructions on how to do this) and choose Destroy from the Edit menu in the Map Editor.


Previous : Contents : Next
© The Numerical Algorithms Group Ltd. Oxford, UK. 2000